首页
登录 | 注册

Linux 安装指定版本GCC方法

今天来记录一下如何安装指定版本gcc,因为在linux中有些软件需要指定gcc的版本,所以记录一下还是很有必要的。好了,直接上安装步骤。

第一步:安装默认版本gcc

首先我们需要安装一个gcc,我们使用yum命令来进行安装。

$ yum install gcc
$ yum install gcc-c++

这两个命令步骤还是很快的。之后我们可以查看我们的gcc版本

这个版本是根据yum版本来下载当前最新版的gcc的,所以可能每个人因为操作系统版本的不同而导致下载的gcc版本会不相同,那么接下来我们来说明一下如何安装指定版本的gcc。

第二步:下载指定版本GCC

首先,我们先到GCC官网去下载GCC的压缩包http://mirror.hust.edu.cn/gnu/gcc/,我们这里选择安装6.4.0版本。Linux 安装指定版本GCC方法

下载完成后,我们将其放到linux中的/usr/local路径下进行解压
Linux 安装指定版本GCC方法

第三步:下载编译所需依赖项

$ cd gcc-6.4.0
$ ./contrib/download_prerequisites 
$ cd ..

第四步:建立编译后文件存放目录

$ mkdir gcc-build-6.4.0
$ cd gcc-build-4.9.4
$ ../gcc-4.9.4/configure --enable-checking=release --enable-languages=c,c++ --disable-multilib

第五步:编译

此步骤会用时很久,本人当时等了一上午。所以稍安勿躁了。

第六步:安装

第七步:查看新版本

Linux 安装指定版本GCC方法



2020 jeepxie.net webmaster#jeepxie.net
10 q. 0.008 s.
京ICP备10005923号