首页
登录 | 注册

Warning: You are using gcc version '4.8.4'. The version currently supported with MEX is '4.7.x'.

Ubuntu14.04 之后,其 g++ 版本已经变为4.8.4,但是 MATLAB 版本的g++还是4.7.x, 所以要想在MATLAB中编译g++ ,我们需要将系统中的g++从4.8.4 变为 4.7.x

步骤如下:
1.添加源并且安装 gcc-4.7 和 g++-4.7

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo  apt-get update
sudo apt-get  install gcc-4.7
sudo apt-get  install g++-4.7

2.确认g++ 安装路径

找到目前gcc版本的路径为:/usr/bin/g++

3.查看 gcc 符号链接于哪个版本

cd /usr/bin/ 
ls -al | grep gcc 

可得目前的gcc符号链接于gcc-4.8.4

4.删除原来gcc符号并链接到gcc-4.7.

sudo rm g++  //删除原来的符号链接
sudo ln -s g++-4.7 g++ //重新创建链接
g++ -v //可见版本已经为4.7了 


2020 jeepxie.net webmaster#jeepxie.net
10 q. 0.008 s.
京ICP备10005923号